Coassemble works well on all modern browsers (a connection to the internet is required).

Compatible browsers include:

  • Apple Safari 10+
  • Google Chrome 81+ (including Chromebooks)
  • Mozilla Firefox 75+
  • Microsoft Edge 81+
  • Opera 67+

Note that we no longer support Internet Explorer, although version 11 may work to some extent.

Updating your browser

If you are experiencing problems using Coassemble and are using an older browser, please consider updating your software…

To update your browser please navigate to the links below:

Mobile access

If you are a learner that has been enrolled in a Course and you are unable to update your browser software, an alternative is to sign-in from your mobile device.

If you have an Android or iPhone, sign in directly from your mobile via the login page.

All of the courses you have access to are 100% mobile-friendly, so you should be able to easily complete them from your mobile.

Did this answer your question?